GC2 - giving really false readings with driver

User avatar
barefoot
Posts: 67
Joined: Mon Nov 30, 2015 7:09 pm
Location: Lime Lake, New York

GC2 - giving really false readings with driver

Postby barefoot » Fri Mar 24, 2017 7:32 pm

Anyone have any ideas?
- Driver readings WAY off-
- What feels like a solid drive (for me, about 220 and slight draw) - GC2 reading about 130-140 yards, and left pull of 40-50 degrees!
- Made sure unit open all the way.
- Ball showing in the middle of the box on screen.
- Started about two weeks ago - got better, now back.
- Using 'rubber' cone tee on a grass mat.
- Every so often, it WILL read what I would consider a normal drive for me, but rare-
- Very frustrating to try and drive the ball -
- Standing over it, and don't know if I should plan for a 150 yard drive way to the left, at a 200 yd drive that will go to the right (due to adjusting)
- No changes to mat, tee, ball, club, etc.


Ironic thing is that irons are reading fine.
Fairway woods are hit miss as well, but not like the driver.

Sucks that it happens this late in season. Will send unit back if need be, but wondering if anyone else has had this phenomenon, and what to do.

Blew this last tournament. Would like to get fixed prior to next week-

Any thoughts / ideas are certainly welcome!

Thanks-
Barefoot-

User avatar
sfr
Posts: 892
Joined: Fri Mar 06, 2015 12:56 pm
Location: Alberta Canada

Re: GC2 - giving really false readings with driver

Postby sfr » Fri Mar 24, 2017 7:53 pm

When you get a wild massive pull read, it is usually something white on the club or possibly the tee that gets picked up and read as the ball going left. Don't use white tees, shoes or pants or even have stickers on the shaft. And I mean you can wear pants.... just not white on them.

I can get away with the white rocket ball headed clubs for some hits but if I roll my club over after impact it will pick up the white and show a massive left and go no where. I tape black over them for the winter.

Other than that if you run the GC2 on battery, when the battery gets low it will miss read as well as delay the shot to display time.
GC2 Simulator Player (Mountain time which is EST -2)

User avatar
psgolfer
Posts: 1072
Joined: Thu Mar 05, 2015 8:40 pm

Re: GC2 - giving really false readings with driver

Postby psgolfer » Fri Mar 24, 2017 9:02 pm

Have you tried another driver? I've heard of the faces caving in and causing issues like your explaining.

I would go to Dicks or somewhere, buy a used driver with the premise that you can return it and test that out.
GC2 PDT

User avatar
barefoot
Posts: 67
Joined: Mon Nov 30, 2015 7:09 pm
Location: Lime Lake, New York

Re: GC2 - giving really false readings with driver

Postby barefoot » Sat Mar 25, 2017 8:00 am

I did get a new driver for Christmas (Titleist 917).

There is the word "Titleist" written in white on the outer end of the club, yet I've been using it since Christmas, with no issues.

I will put electrical tape on the end, and see if that helps.

The 'rubber cone' tee is yellow, and I'll also put electrical tape around the tee to see if that helps.

I do notice that the rubber cone tee does typically fly/go to the left on a drive- Maybe the GC2 is picking up the tee instead of the ball? If so, why would it "just start" now?

User avatar
psgolfer
Posts: 1072
Joined: Thu Mar 05, 2015 8:40 pm

Re: GC2 - giving really false readings with driver

Postby psgolfer » Sat Mar 25, 2017 10:54 am

I had the odd issue with white rubber tee's, so I switched to birdtee (I use the orange ones) and have never had the gc2 pick up the tee.

Seems strange though for you to be having this issue so late in the season. Is your GC2 serial number lower than 2500? Try running the tilt/calibration tool if it is lower than 2500.

Other than that, what about your 3 wood? Do you have similar issues with that club?
GC2 PDT

User avatar
barefoot
Posts: 67
Joined: Mon Nov 30, 2015 7:09 pm
Location: Lime Lake, New York

Re: GC2 - giving really false readings with driver

Postby barefoot » Sat Mar 25, 2017 7:32 pm

Taped the tee (with electrical tape) and the driver- All seems back to normal.

Guessing maybe the (yellow) rubber tee taking on a 'sheen' from use through the season? Nonetheless, seems to have gone away with the electrical tape on the tee. Will investigate the bird tees. (Thanks!)

S/N is below 2500 - will run the new calibration (from another post) - may wait until after the season though... just in case another issue arises.

Played last round of this weekends tournament, and played bear mountain - seems to be back to normal.

Thanks all!


Return to “Foresight GC2”

Who is online

Users browsing this forum: No registered users and 5 guests